База знаний

Итак, для настройки маршрутизатора с функцией PPPoE необходимо иметь правильное программное обеспечение. В нашем случае, это Cisco IOS версии 12.1.2T опция IP PLUS:

  • boot system flash c2600-is-mz.121-2.T.bin

Стандартные настройки для сервера RADIUS для аутентификации, авторизации и учета работы пользователей:

  • aaa new-model
  • aaa authentication ppp default group radius
  • aaa authorization network default group radius
  • aaa accounting network default start-stop group radius

Разрешение функционирования маршрутизатора с функцией виртуальных частных сетей:

  • vpdn enable
  • no vpdn logging

Создание VPDN группы для приема соединений типа PPPoE и использования для них "заготовки" virtual-template 1:

  • vpdn-group 1
  • accept-dialin
  • protocol pppoe
  • virtual-template 1

Разрешение приема соединений PPPoE на интерфейсе FastEthernet0/0:

  • interface FastEthernet0/0
  • ip address 192.168.0.1 255.255.255.0
  • duplex auto
  • speed auto
  • pppoe enable

Создание заготовки Virtual-Template 1, в которой адрес клиенту выделяется динамически из пула адресов под названием TEST, используется аутентификация пользователей по протоколам PAP и CHAP, а так как для пользователей используются приватные адреса, маршрутизатор настроен с использованием функции трансляции адресов NAT:

  • interface Virtual-Template1
  • ip address 192.168.100.1 255.255.255.0
  • ip nat inside
  • peer default ip address pool TEST
  • ppp authentication chap pap callin

Команды глобального режима конфигурации для создания пула адресов "TEST" и использования функции NAT overload на интерфейсе Serial0/0 для адресов из access-list 1:

  • ip local pool TEST 192.168.100.2 192.168.100.254
  • ip nat inside source list 1 interface Serial0/0 overload
  • access-list 1 permit 192.168.100.0 0.0.0.255
  • ip route 0.0.0.0 0.0.0.0 195.195.195.1

Команды глобального режима конфигурации для назначения RADIUS сервера:

  • radius-server host 192.168.1.2 auth-port 1645 acct-port 1646
  • radius-server retransmit 3
  • radius-server key test

При такой конфигурации маршрутизатора пользователи, подключенные к сети Ethernet, не могут работать с доступом в Интернет, не используя технологию PPPoE и не пройдя аутентификацию в сервере RADIUS, потому что функция NAT будет реализована только для адресов пользователей службы PPPoE.

Приведенная конфигурация маршрутизатора тестировалась со следующим программным обеспечением:

  • EtherNet 300, разработанным компанией Efficient Network, 30 дней бесплатно, стоимость 29$, (http://www.nts.com/). Установлено на Windows NT 4.0.
  • POETRI, 30 дней бесплатно. Установлено на Windows 95 и Windows NT 4.0 PPPoE клиент для Linux. (http://www.brightdsl.net/). Установлено на Red Hat 7.0.
  • В качестве биллинговой системы была использована система "Билл-Мастер".

Помимо тестирования взаимодействия программного обеспечения персональных компьютеров с оборудованием концентратора доступа клиентов, было протестировано применение технологии PPPoE совместно с оборудованием доступа ADSL. Схема этого испытания приведена на рисунке 2. Такое применение PPPoE позволяет настроить ADSL-модем/ADSL-маршрутизатор клиента (необходимо указать имя пользователя, пароль и т.д.) и аутентифицировать на концентраторе доступа через RADIUS биллинговую систему. При этом, трафик пользователей всей локальной сети организации будет учтен как общий, но в такой конфигурации на компьютерах пользователей не нужно иметь программное обеспечение PPPoE клиентов, так как его роль выполняет ADSL оборудование (ADSL-Модем/ADSL-Маршрутизатор Telindus 1120).

Биллинг

В сети Интернет кроме протестированного, можно найти другое программное обеспечение PPPoE клиента для разных операционных систем, например, таких как Mac, BeOS. Также можно найти программное обеспечение для написания своего специфичного клиента под определенные услуги какого-либо провайдера.

Как было сказано в начале статьи, PPPoE является новой технологией, и время ее широкого применения еще не наступило. Несмотря на это, уже сейчас видна заинтересованность крупных операторов связи и услуг Интернет (France Telecom, Prodigy) в использовании этой технологии совместно с технологией DSL.